Loading...

May 29, 2008

NetBeans Maven support 3.1.2 has a problem with long version numbers

This week I updated the NetBeans Maven support with version 3.1.2. But after the update some of my old projects could not be read correctly by NetBeans. It turned out to be a NumberFormatException for an input string "20050307052300". This turned out to be the version number of an dependency, which was used by another dependency in my project. The exception seems to come from the embedded Maven. Luckily I could exclude this dependency from my pom.xml and NetBeans could work with my projects again.

This issue will be fixed in version 3.1.4 of the plugin.